?

Log in

No account? Create an account

rauf


Блог Алиева Рауфа

О жизни и о себе


Сказка про репку от ллео
rauf
Новое видение сказки про репку от Лёни Каганова. Это просто шедевр!

чем бы озаглавить…
rauf
Вчера я сделал над собой усилие и разобрался. Теперь я знаю, как сделать условное суммирование в экселе.

К примеру, вы ведете в экселе свои расходы.

И стоит задача просуммировать для каждой статьи расходов. Вручную это делается сортировкой по полю "Статья расходов" и потом суммированием либо в интерактивном режиме (выделяем мышью и смотрим вниз, в графу "Сумма"), либо формулой суммирования смежных ячеек типа =СУММ(B3:B100). При этом автоматизмом в обоих случаях не пахнет — можно ответить только на один вопрос, типа "сколько я трачу на еду". А если статей с полсотни?

В excel есть формула условного суммирования СУММЕСЛИМН (диапазон суммирования; диапазон критериев; условие). В данном случае напротив каждого пункта статьи расходов стоит формула: =СУММЕСЛИМН('журнал расходов'!C3:C8;'журнал расходов'!B3:B8;Сводное!B3).

Третий параметр может включать звездочки (*) и вопросительные знаки (?). Звездочки заменяют собой любое количество символов. Это позволяет в данном примере указывать для каждой записи несколько статей расходов. Тогда третьим параметром («условие») нужно указать формулу, для каждой категории создающей что-то типа =*еда*
. Это означает команду выбрать все значения столбца В, где упоминается "еда" (правда, нужно быть аккуратнее, будут выбираться и "беда", и "ябеда", и "корябеда"...). При этом кроме "еды" там может упоминаться и другое. Для того, чтобы формировать =*статья расходов* для каждой статьи расходов, нужно использовать функцию СЦЕПИТЬ:
= СЦЕПИТЬ("=*";B3;"*")
Итого выйдет что-то такое:
=СУММЕСЛИМН('журнал расходов'!C3:C8;'журнал расходов'!B3:B8;СЦЕПИТЬ("=*";Сводное!B3;"*"))